  <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
  <html lang="en" prefix="og: http://ogp.me/ns#">
  <head>
  <title>Passwords and Hacking: The Jargon of Cybercrime Explained | Enterprise Security Today</title>
  <meta property="og:title" content="Passwords and Hacking: The Jargon of Cybercrime Explained | Enterprise Security Today" />
  <meta property="og:type" content="website" />
  <meta property="og:url" content="http://www.enterprise-security-today.com/story.xhtml?story_id=113003WCSG6F" />
  <meta property="og:image" content="http://www.enterprise-security-today.com/images/super/larger-16-HACK-with-password-login-PC-2.jpg" />
  <meta property="og:image:type" content="image/jpg">
  <meta property="og:image:width" content="593">
  <meta property="og:image:height" content="290">
  <meta property="og:description" content="With each hack that makes the news there’s the big question of how well the site protected its users’ data. Was it open and freely available, or was it hashed, secured and practically unbreakable?
" />
  <meta prefix="fb: http://ogp.me/ns/fb#" property="fb:app_id" content="104421319604025">
  <!-- twitter meta -->
  <meta name="twitter:card" content="summary_large_image">
  <meta name="twitter:site" content="@newsfactor">
  <meta name="twitter:title" content="Passwords and Hacking: The Jargon of Cybercrime Explained | Enterprise Security Today">
  <meta name="twitter:description" content="With each hack that makes the news there’s the big question of how well the site protected its users’ data. Was it open and freely available, or was it hashed, secured and practically unbreakable?
">
  <meta name="twitter:image:src" content="http://www.enterprise-security-today.com/images/super/larger-16-HACK-with-password-login-PC-2.jpg">
  <!-- / twitter meta -->
  <meta name="medium" content="news" />
  <meta name="title" content="Passwords and Hacking: The Jargon of Cybercrime Explained | Enterprise Security Today - Network Security News" />
  <meta http-equiv="Content-Type" content="text/html;charset=UTF-8" />
  <meta name="headline" content="Passwords and Hacking: The Jargon of Cybercrime Explained | Enterprise Security Today - Network Security News" />
  <meta name="created" content="2016-12-18 07:28:32" />
  <meta name="DC.date.issued" content="2016-12-18"> 
  <meta name="keywords" content="Cybercrime,Cybersecurity,Cyberattack,Data Breach,Password,Encryption,Hacker,Intrusion" />
  <meta name="description" content="With each hack that makes the news there’s the big question of how well the site protected its users’ data. Was it open and freely available, or was it hashed, secured and practically unbreakable?
" />
  <meta name="syndication-source" content="http://www.enterprise-security-today.com/story.xhtml?story_id=113003WCSG6F" />
  <META name="ROBOTS" content="NOARCHIVE" />
  <META name="Expires" content="0" />
  <META Http-Equiv="Expires" Content="0" />
  <META Http-Equiv="Cache-Control" Content="no-cache" />
  <META Http-Equiv="Pragma" Content="no-cache" />
  <link rel="alternate" type="application/rss+xml" title="Enterprise Security Today RSS Feed" href="/share/rss_feed.php" />
  <link rel="SHORTCUT ICON" HREF="http://newsfactor.com/favicon.ico" />
  <link rel="canonical" href="http://www.enterprise-security-today.com/story.xhtml?story_id=113003WCSG6F" />
  <link rel="stylesheet" href="//code.jquery.com/ui/1.11.1/themes/smoothness/jquery-ui.css">
  <link rel="stylesheet" href="/share/nfn-style-2012.css" type="text/css" />
  <link href='http://fonts.googleapis.com/css?family=Oxygen' rel='stylesheet' type='text/css'>
  <link href="http://fonts.googleapis.com/css?family=Bree+Serif" rel="stylesheet" type="text/css">
  <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>
  <script src="http://code.jquery.com/ui/1.11.1/jquery-ui.js"></script>
  <! -- script src="/share/nfn_extra_script1_14.js"--><!-- /script-->
  <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  
    ga('create', 'UA-2948378-1', 'auto');
    ga('send', 'pageview');
  
  </script>
  <script>(function() {
    var _fbq = window._fbq || (window._fbq = []);
    if (!_fbq.loaded) {
      var fbds = document.createElement('script');
      fbds.async = true;
      fbds.src = '//connect.facebook.net/en_US/fbds.js';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(fbds, s);
      _fbq.loaded = true;
    }
    _fbq.push(['addPixelId', '1469526266648474']);
  })();
  window._fbq = window._fbq || [];
  window._fbq.push(['track', 'PixelInitialized', {}]);
  </script>
  <noscript><img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=1469526266648474&amp;ev=NoScript" /></noscript>

      <script>
        $(document).ready(function(){
            // Next Article
           var nextArticleURL = "/share/nfn_ajaxFunctions14.php?do=5RT82WD&params=" + $("#activateNextArticle").attr("name");
           $("#nextArticleCanvass").load (nextArticleURL);

            // Tooltips
            $(function() {
              $(document).tooltip();
            });

            // Toggles the top site menu
            $( "#siteMenuActivate" ).add( "#closeMenuCanvass" ).click(function() {
              $( "#siteMenuCanvass" ).slideToggle( "slow" );
              $( "#siteMenuCanvass" ).css('position', 'fixed');
            });

            $( "#superGraphicTeaserActivate" ).click(function() {
              $( "#superGraphicTeaser" ).slideToggle( "slow" );
              $('#superGraphicTeaserRiserContainer').slideToggle( "slow" ); 
            });

            $('#superGraphicTeaserRiserActivate').mouseenter(function() {
              $( "#superGraphicTeaser" ).slideToggle( "slow" );
              $('#superGraphicTeaserRiserContainer').slideToggle( "slow" );
            });

            // Closes the welcome ad
            $( "#rollupbutton" ).click(function() {
              $( "#expandable_welcome_ad" ).slideToggle( "slow" );
            });

            // Closes the breaking news announcement box
            $( "#announcement_cls" ).click(function() {
              $( "#annoucement_canvass" ).toggle( "fade" );
              $.cookie("spc_annc", 1);
            });

            $(window).scroll(function(){
               // Causes the fixed top row shadow to appear 
               if ($(this).scrollTop() > 5) {
                  $('#shadow4fixedDiv').fadeIn("slow");
               } else {
                   $('#shadow4fixedDiv').hide();
                 }
            });

        });
      </script>

      <script src="http://www.enterprise-security-today.com/share/showads.js"></script>
  </head>
  <body>

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=104421319604025&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<script>
   $(document).ready(function(){
      //ab_detection
      function showAbNotice() {
       $('#screen_cover').toggle();
       $('#ab_notice').toggle('slow');   
      } 
      if( window.canRunAds === undefined ){
       // adblocker detected, show fallbac
       showAbNotice();
      }
      $( "#ab_notice_closer" ).click(function() {
        $( "#ab_notice" ).toggle( "fade" );
        $( "#screen_cover" ).toggle( "fade" );
      });
   });
    </script>

   <center>
<div id="screen_cover" class="entire_screen_cover">
</div>
  <div id="ab_notice" class="ab_notice_canvass">
   <div class="inner_ab_notice">
    <div class="top_and_bottom_borders">
    <div style="font-size:18pt;">
      Dear Visitor,
    </div>
  <p>
  Our system has found that you are using an ad-blocking browser add-on.
  <p>
  We just wanted to let you know that our site content is, of course,
  available to you absolutely free of charge.
  <p>
  Our ads are the only way we have to be able to bring you the latest
  high-quality content, which is written by professional journalists,
  with the help of editors, graphic designers, and our site production
  and I.T. staff, as well as many other talented people who work around the clock
  for this site.
  <p>
  So, we ask you to add this site to your Ad Blocker’s "white list" or
  to simply disable your Ad Blocker while visiting this site.
  <p>
  <div style="padding-top:10px;">
   <span id="ab_notice_closer" class="bigBtn14" style="display:inline-block;">
    Continue on this site freely
   </span>
     </div>
    </div>
   </div>
  </div>
<div class="spacerRow"></div>

        <div class="fixedHeader"> 
         <div style="background:#222;">
          <table width="980" cellpadding="0" cellspacing="0" border="0">
           <tr>
            <td style="background:#990000;width:250px;">&nbsp;</td>
            <td style="padding-left:10px;padding-right:10px;">
              <span class="smallWhiteLinks14" id="homeLinkActivate"><a title="Home" href="http://www.enterprise-security-today.com"><img src="http://www.enterprise-security-today.com/share/images/site/icon-home14.png" width="14" height="14" border="0" style="padding-right:5px;">HOME</a></span> &nbsp; &nbsp; 
              <span class="smallWhiteLinks14" id="siteMenuActivate"><a title="Site Menu" href="#"><img src="http://www.enterprise-security-today.com/share/images/site/icon-menu14.png" width="14" height="14" border="0" style="padding-right:5px;">MENU</a></span> &nbsp; &nbsp;
            </td>
            <td align="right">
              <span class="smallWhiteLinks14"><a title="Search This Site" data-transition="slidedown" href="http://www.enterprise-security-today.com/search.xhtml"><img src="http://www.enterprise-security-today.com/share/images/site/icon-search14.png" width="14" height="14" border="0" style="padding-right:5px;">SEARCH</a></span> &nbsp; &nbsp;
              <span class="smallWhiteLinks14"><a title="Stay Up To Date With A Free Newsletter" href="http://www.newsfactor.com/members.xhtml"><img src="http://www.enterprise-security-today.com/share/images/site/icon-newsletter14.png" width="14" height="14" border="0" style="padding-right:5px;">NEWSLETTER</a></span> &nbsp; &nbsp;
            </td>
            <td style="background:#fff;width:108px;padding-top:5px;" align="center">
             <a title="Follow us on Facebook" href="https://www.facebook.com/Newsfactornetwork"><img id="moreTransparency1" src="http://www.enterprise-security-today.com/share/images/site/icon-facebook-grey2.png" width="23" height="24" border="0"></a>
             <a title="Follow our Twitter feed" href="https://twitter.com/newsfactor"><img id="moreTransparency1" style="padding-left:15px;" src="http://www.enterprise-security-today.com/share/images/site/icon-twitter-grey2.png" width="28" height="24" border="0"></a> 
            </td>
           </tr>
          </table>
         </div>
         <div style="background:#fff;display:block;padding-bottom:20px;padding-top:0px;">
          <table width="980" cellpadding="0" cellspacing="0" border="0">
           <tr>
            <td align="center" style="background:#990000;width:250px;border-top:#990000 solid 1px;border-radius:0px 0px 5px 5px;"><a title="Home" href="http://www.enterprise-security-today.com" target="_top"><img id="notransparency" src="http://images.newsfactor.com/share/images/site/est-logo.gif" width="387" height="26" border="0"></a></td>
            <td class="tinyText14" style="background:#fff;padding-left:10px;">
             THE ENTERPRISE SECURITY SUPERSITE. UPDATED ABOUT A MINUTE AGO.
            </td>
          </table>
         </div>

  <!-- Site Menu -->
  <div id="siteMenuCanvass" class="siteMenuCanvass">
          <div class="stdLinks" style="text-align:left;padding:10px;">
            <div style="position:absolute;top:1px;right:-4px;"><a href="#"><img id="closeMenuCanvass" src="http://www.enterprise-security-today.com/share/images/site/close-round1.png" width="42" height="42" border=""></a></div>
            <div class="siteMenuItem"><a href="http://www.enterprise-security-today.com">Home</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=75">Network Security</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=5">Viruses & Malware</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=244">Cybercrime</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=160">Security Solutions</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=207">Mobile Security</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=262">Disaster Recovery</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=159">Windows Security</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=212">Data Security</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=155">EST Contributed Content</a></div>  </div>
         </div>
<!-- // Site Menu -->
         <div class="shadowRow1" id="shadow4fixedDiv"></div>
        </div><table cellpadding="0" cellspacing="0" border="0" width="980">
             <tr>
              <td> <div class="nfnNavCrumbs14" style="border-top:#ccc8c8 solid 1px;border-bottom:#ccc8c8 solid 1px;margin-top:10px;margin-bottom:10px;"><img src="http://images.newsfactor.com/share/images/site/spacer.gif" width="5" height="38" border="0" align="absmiddle">
              You are here: 
              <a href="http://www.enterprise-security-today.com">Home</a> / <a href='http://www.enterprise-security-today.com/section.xhtml?category=075'>Network Security</a> / Passwords, Hacking Jargon Explained</div></td>
              <td align="right"> <div class="nfnNavCrumbs14" style="height:24px;padding:7px;border-top:#ccc8c8 solid 1px;border-bottom:#ccc8c8 solid 1px;margin-top:10px;margin-bottom:10px;">
</div></td>
           </tr>
           <tr>
            <td colspan="2">
              <table cellpadding="0" cellspacing="0" border="0" width="100%">
                <tr> <td style="padding-top:3px; padding-bottom:3px;"></td> <td style="padding-top:3px; padding-bottom:3px;" align="center" width='240'>    </td>
                    </tr>
                 </table>
                </td>
           </tr>
  
  </table>
  <!-- / Fade -->  
  
<table cellpadding="0" cellspacing="0" width="980" border="0">
           <tr>
            <td valign="top" bgcolor="#FFFFFF"><!--body-->
         <div class='regtext'>
 <div style="border-top:#555 solid 3px;margin-top:10px;margin-bottom:10px;"></div>
         <table cellpadding="0" cellspacing="0" border="0">
         <tr>
          <td colspan="2" style="border-right:#ddd solid 1px;" valign="top">
           <div style="padding:5px;">
            <img id="notransparency" src="http://www.sci-tech-today.com/images/super/larger-16-HACK-with-password-login-PC-2.jpg" width="100%" border="0" alt="Passwords and Hacking: The Jargon of Cybercrime Explained">
           </div>
           <div class="articleHeadline14">
            Passwords and Hacking: The Jargon of Cybercrime Explained
           </div>
           <div style="padding:10px;border-top:#999 solid 1px;border-bottom:#999 solid 1px;">
            <table cellpadding="0" cellspacing="0" width="100%">
             <tr> <!--byline-->
            <td class='articleByline14'>By Samuel Gibbs </td>
           <!--/byline-->
         <td align="right">
                <a title="Share this on Facebook" href="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.enterprise-security-today.com/story.xhtml?story_id=113003WCSG6F&t=Passwords+and+Hacking%3A+The+Jargon+of+Cybercrime+Explained"><img id="moreTransparency1" src="http://images.newsfactor.com/share/images/site/icon-facebook-round.png" width="25" height="27" border="0" alt="Like this on Facebook"></a>
                <a title="Share this on Twitter" href="http://twitter.com/intent/tweet?text=Passwords+and+Hacking%3A+The+Jargon+of+Cybercrime+Explained&url=http%3A%2F%2Fwww.enterprise-security-today.com/story.xhtml?story_id=113003WCSG6F"><img id="moreTransparency1" src="http://images.newsfactor.com/share/images/site/icon-twitter-round.png" width="25" height="27" border="0" alt="Tweet this"></a>
                <a title="Share this on LinkedIn" href="http://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fwww.enterprise-security-today.com/story.xhtml?story_id=113003WCSG6F&title=Passwords+and+Hacking%3A+The+Jargon+of+Cybercrime+Explained&summary=With+each+hack+that+makes+the+news+there%26acirc%3B%80%99s+the+big+question+of+how+well+the+site+protected+its+users%26acirc%3B%80%99+data.+Was+it+open+and+freely+available%2C+or+was+it+hashed%2C+secured+and+practically+unbreakable%3F%0D%0A&source=Enterprise Security Today"><img id="moreTransparency1" src="http://images.newsfactor.com/share/images/site/icon-linkedin-round.png" width="25" height="27" border="0" alt="Link thison Linkedin"></a>
                <a title="Share this on Google+" href="https://plus.google.com/share?url=http%3A%2F%2Fwww.enterprise-security-today.com/story.xhtml?story_id=113003WCSG6F"><img id="moreTransparency1" src="http://images.newsfactor.com/share/images/site/icon-googleplus-round.png" width="25" height="27" border="0" alt="Link this on Google Plus"></a>
               </td>
              </tr>
             </table>
           </div>

          <div style="float:left; padding:5px 10px 15px; 15px; width:160px; height:100%;"><div class="fancyDateContainer">
                   <div class="fancydatePublished">PUBLISHED:</div>
                   <div class="fancydateMonth">DECEMBER</div>
                   <div class="fancyDateDay">18</div>
                   <div class="fancydateYear">2016</div>
                  </div>
            <div align='center' valign='top' class='smallText'>
          <!-- Start Skyscraper ad -->
          <!img src='http://images.enterprise-security-today.com/images/tiny-advertisement.gif' alt='Advertisement' border='0'><!br>
<!-- End Skyscraper ad -->
          </div><br>
      </div><div style="padding:0px;float:right;"><iframe id='editcheck' name='editcheck' src='http://www.newsfactor.com/share/new_editcheck.xhtml?story_id=103959' width='100' height='5' frameborder='0' scrolling='no' MARGINWIDTH='0' MARGINHEIGHT='0' HSPACE='0' VSPACE='0' FRAMEBORDER='0' SCROLLING='no' BORDERCOLOR='#000000'>
          </iframe>
</div>
               <div id="Main_body" class="articleBodyText14" style="padding:10px;">
             From Yahoo, MySpace and TalkTalk to Ashley Madison and Adult Friend Finder, personal information has been stolen by hackers from around the world.
<p>
But with each hack there’s the big question of how well the site protected its users’ data. Was it open and freely available, or was it hashed, secured and practically unbreakable?
<p>
From cleartext to hashed, salted, peppered and bcrypted, here’s what the impenetrable jargon of password security really means.
<p>
<span class='subhead'>
The Terminology 
</span>
<p>
<I>Plain Text</I>
<p>
When something is described being stored as “cleartext” or as “plain text” it means that thing is in the open as simple text -- with no security beyond a simple access control to the database which contains it.
<p>
If you have access to the database containing the passwords you can read them just as you can read the text on this page.
<p>
<I>Hashing</I>
<p>
When a password has been “hashed” it means it has been turned into a scrambled representation of itself. A user’s password is taken and -- using a key known to the site -- the hash value is derived from the combination of both the password and the key, using a set algorithm.
<p>
To verify a user’s password is correct it is hashed and the value compared with that stored on record each time they login.
<p>
You cannot directly turn a hashed value into the password, but you can work out what the password is if you continually generate hashes from passwords until you find one that matches, a so-called brute-force attack, or similar methods.
<p>
<I>Salting</I>
<p>
Passwords are often described as “hashed and salted”. Salting is simply the addition of a unique, random string of characters known only to the site to each password before it is hashed, typically this “salt” is placed in front of each password.
<p>
The salt value needs to be stored by the site, which means sometimes sites use the same salt for every password. This makes it less effective than if individual salts are used.
<p>
The use of unique salts means that common passwords shared by multiple users -- such as “123456” or “password” -- aren’t immediately revealed when one such hashed password is identified -- because despite the passwords being the same the salted and hashed values are not. 
<p>
Large salts also protect against certain methods of attack on hashes, including rainbow tables or logs of hashed passwords previously broken.
<p>
Both hashing and salting can be repeated more than once to increase the difficulty in breaking the security.
<p>
<I>Peppering</I>
<p>
Cryptographers like their seasonings. A “pepper” is similar to a salt -- a value added to the password before being hashed -- but typically placed at the end of the password.
<p>
There are broadly two versions of pepper. The first is simply a known secret value added to each password, which is only beneficial if it is not known by the attacker.
<p>
The second is a value that’s randomly generated but never stored. That means every time a user attempts to log into the site it has to try multiple combinations of the pepper and hashing algorithm to find the right pepper value and match the hash value.
<p>
Even with a small range in the unknown pepper value, trying all the values can take minutes per login attempt, so is rarely used.
<p>
<I>Encryption</I>
<p>
Encryption, like hashing, is a function of cryptography, but the main difference is that encryption is something you can undo, while hashing is not. If you need to access the source text to change it or read it, encryption allows you to secure it but still read it after decrypting it. Hashing cannot be reversed, which means you can only know what the hash represents by matching it with another hash of what you think is the same information.
<p>
If a site such as a bank asks you to verify particular characters of your password, rather than enter the whole thing, it is encrypting your password as it must decrypt it and verify individual characters rather than simply match the whole password to a stored hash.
<p>
Encrypted passwords are typically used for second-factor verification, rather than as the primary login factor.
<p>
<I>Hexadecimal</I>
<p>
A hexadecimal number, also simply known as “hex” or “base 16”, is way of representing values of zero to 15 as using 16 separate symbols. The numbers 0-9 represent values zero to nine, with a, b, c, d, e and f representing 10-15.
<p>
They are widely used in computing as a human-friendly way of representing binary numbers. Each hexadecimal digit represents four bits or half a byte.
<p>
<span class='subhead'>
The Algorithms 
</span>
<p>
<I>MD5</I>
<p>
Originally designed as a cryptographic hashing algorithm, first published in 1992, MD5 has been shown to have extensive weaknesses, which make it relatively easy to break.
<p>
Its 128-bit hash values, which are quite easy to produce, are more commonly used for file verification to make sure that a downloaded file has not been tampered with. It should not be used to secure passwords.
<p>
<I>SHA-1</I>
<p>
Secure Hash Algorithm 1 (SHA-1) is cryptographic hashing algorithm originally design by the US National Security Agency in 1993 and published in 1995.
<p>
It generates 160-bit hash value that is typically rendered as a 40-digit hexadecimal number. As of 2005, SHA-1 was deemed as no longer secure as the exponential increase in computing power and sophisticated methods meant that it was possible to perform a so-called attack on the hash and produce the source password or text without spending millions on computing resource and time.
<p>
<I>SHA-2</I>
<p>
The successor to SHA-1, Secure Hash Algorithm 2 (SHA-2) is a family of hash functions that produce longer hash values with 224, 256, 384 or 512 bits, written as SHA-224, SHA-256, SHA-384 or SHA-512.
<p>
It was first published in 2001, designed by again by the NSA, and an effective attack has yet to be demonstrated against it. That means SHA-2 is generally recommended for secure hashing.
<p>
SHA-3, while not a replacement for SHA-2, was developed not by the NSA but by Guido Bertoni, Joan Daemen, Michaël Peeters and Gilles Van Assche from STMicroelectronics and Radboud University in Nijmegen, Netherlands. It was standardised in 2015.
<p>
<I>Bcrypt</I>
<p>
As computational power has increased the number of brute-force guesses a hacker can make for an efficient hashing algorithm has increased exponentially.
<p>
Bcrypt, which is based on the Blowfish cipher and includes a salt, is designed to protect against brute-force attacks by intentionally being slower to operate. It has a so-called work factor that effectively puts your password through a definable number of rounds of extension before being hashed.
<p>
By increasing the work factor it takes longer to brute-force the password and match the hash. The theory is that the site owner sets a sufficiently high-enough work factor to reduce the number of guesses today’s computers can make at the password and extend the time from days or weeks to months or years, making it prohibitively time consuming and expensive.
<p>
<I>PBKDF2</I>
<p>
Password-Based Key Derivation Function 2 (PBKDF2), developed by RSA Laboratories, is another algorithm for key extension that makes hashes more difficult to brute force. It is considered slightly easier to brute force than Bcrypt at a certain value because it requires less computer memory to run the algorithm.
<p>
<I>Scrypt</I>
<p>
Scrypt like Bcrypt and PBKDF2 is an algorithm that extends keys and makes it harder to brute-force attack a hash. Unlike PBKDF2, however, scrypt is designed to use either a large amount of computer memory or force many more calculations as it runs.
<p>
For legitimate users having to only hash one password to check if it matches a stored value, the cost is negligible. But for someone attempting to try 100,000s of passwords it makes cost of doing so much higher or take prohibitively long.
<p>
<span class='subhead'>
But What About the Passwords? 
</span>
<p>
If a password is properly hashed using SHA-2 or newer, and is salted, then to break a password requires a brute-force attack. 
<p>
The longer the password, the longer the brute-force attack is going to last. And the longer the brute-force attack required, the more time-consuming and expensive it is to match the hash and discover the password.
<p>
Which means the longer the password the better, but the configuration of the password also makes a difference. A truly random eight-character password will be more secure than a eight-letter dictionary word, because brute-force attacks use dictionaries, names and other lists of words as fodder.
<p>
However, if the site stores your password as plain text it doesn’t matter how long your password is if the database is stolen.
<!--copyright-->
           <div class="smalltext" style="padding:15px 0px 10px 0px;">&copy; 2016 Guardian Web under contract with NewsEdge. All rights reserved.</div>
          <!--/copyright-->
<div style="clear:both;padding:15px 15px 25px 0px;">
          <b>Read more on:</b> <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Cybercrime%22&sort=time">Cybercrime</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Cybersecurity%22&sort=time">Cybersecurity</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Cyberattack%22&sort=time">Cyberattack</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Data+Breach%22&sort=time">Data Breach</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Password%22&sort=time">Password</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Encryption%22&sort=time">Encryption</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Hacker%22&sort=time">Hacker</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Intrusion%22&sort=time">Intrusion</a></div><div style="clear:both;"><div style='background:#DCE2ED;padding:7px;border:#ACB1BA solid 1px;'>
                    <table cellpadding='3' cellspacing='0'>
                     <form action='' method='post'>
                     <tr>
                      <td colspan='2'>
                       <div class='bigDate'>Tell Us What You Think</div>
                      </td>
                     </tr>
                     <tr>
                     <td valign='top' class='smallText14' colspan='2'>
                      <b>Comment:</b>
                      <br>
                      <textarea style='font-size:12pt;' cols='55' rows='5' name='comment_body'></textarea>
        <p>
      <b>Name:</b><br><input type='text' size='30' name='comment_username' style='font-size:12pt;'>
                      </td>
                     </tr>
                     <tr>
                     <td>
                      <input type='hidden' name='comment_aid' value='103959'>
                      <input type='hidden' name='do' value='PREVIEW YOUR COMMENT'>
                      <input type='hidden' name='article_title' value='Passwords and Hacking: The Jargon of Cybercrime Explained'>
                      <input type='submit' value='Send' class='regBtn14'>
                     </td>
                     </tr>
                     </form>
                    </table>
                    </div><p></div>  </div>
          </td>
          <td width="320" valign="top" align="center">
           <div style="padding:5px;border-bottom:#ccc solid 1px;">
            <a title="Like / Follow us on Facebook" href="https://www.facebook.com/Newsfactornetwork"><img src="http://images.newsfactor.com/share/images/site/like-us.png" width="150" height="34" border="0" alt="Like Us on Facebook"></a><a title="Follow our Twitter Feed" href="https://twitter.com/newsfactor"><img src="http://images.newsfactor.com/share/images/site/follow-us.png" width="150" height="34" border="0" alt="Follow Us on Twitter"></a>
           </div>
           <div style="padding-top:10px;padding-bottom:20px;">   </div> <div style="padding-top:0px;padding-bottom:20px;"> <div class="sidePanelTitle"">
            <span style="color:#990000;">TOP STORIES</span> NOW
           </div>
           <img src="http://www.newsfactor.com/images/2012/imu_shadow.gif">
          <div style="text-align:left;padding-top:0px;padding-bottom:25px;">
           <div class="sidepanelitem"><span class="greyText1">1.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=1130009JDSOW">2016 Cybercrime and Worst Hacks</a><p><span class="greyText1">2.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=1130009JDMOB">Intel Security Seeks New Paradigm</a><p><span class="greyText1">3.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=1130009JDS2X">Mark Zuckerberg Shows Off Jarvis</a><p><span class="greyText1">4.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=1130009JDRGY">Cyber Insurance Key as Hacks Rise</a><p><span class="greyText1">5.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=1130009JDLPS">New Year, New Threats to Security</a><p> </div>
         </div><div class="sidePanelTitle">
          <span style="color:#990000;">MAY INTEREST</span> YOU 
         </div>
        <img src="http://www.newsfactor.com/images/2012/imu_shadow.gif">
        <div style="padding:10px;padding-top:0px;padding-bottom:20px;">
          <div class="cipText14" style="padding:10px;padding-top:0px;text-align:left;"> </div>
         </div> <div style="padding-top:10px;padding-bottom:20px;"> </div>
         </div>
           <div class="sidePanelTitle"><span style="color:#990000;">MORE IN</span> NETWORK SECURITY
           </div>
           <img src="http://www.newsfactor.com/images/2012/imu_shadow.gif">
<div class="sidePanelItem"><span class="greyText1">1.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=113003WCSJR4">2016 Cybercrime and Worst Hacks</a></div><div class="sidePanelItem"><span class="greyText1">2.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=113003WCSIJ6">Cyber Insurance Key as Hacks Rise</a></div><div class="sidePanelItem"><span class="greyText1">3.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=113003WCSGSE">Yahoo Had 1 Billion Accounts Hacked</a></div><div class="sidePanelItem"><span class="greyText1">4.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=113003WCSG6F">Passwords, Hacking Jargon Explained</a></div><div class="sidePanelItem"><span class="greyText1">5.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=113003WCSFX0">Yahoo's Big Breach: Hacker Anxiety</a></div><div style="padding-top:20px;padding-bottom:20px;"></div>
           </td>
          </tr> </table> 
         
           <div style="border-top:#444 solid 3px;border-bottom:#444 solid 2px;margin-top:25px;" id="activateNextArticle" name="113003WCSG6F-75">
            <div class="stdLinks">Next Article ></div>
            <div class="nextArticleContainer">
             <div id="nextArticleCanvass"> </div>
           </div>
           </div>

          </td>
         </tr>
     </table>

<!-- Navigation -->
          <div style="background:#eee; border-top:#c0c0c0 solid 5px;margin-top:20px;padding-top:20px;">
           <table cellpadding="5" cellspacing="0" width="980" border="0">
           <tr>
             <td width="33%" valign="top" style="border-right:#ccc solid 1px;">
               <div class="sidePanelTitle">
               ENTERPRISE SECURITY TODAY
               </div>
               <div>
                <ul><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=75'>Network Security</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=5'>Viruses & Malware</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=244'>Cybercrime</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=160'>Security Solutions</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=207'>Mobile Security</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=262'>Disaster Recovery</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=159'>Windows Security</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=212'>Data Security</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=155'>EST Contributed Content</a>
                </ul>
               </div>
             </td>

             <td width="33%" valign="top"  style="border-right:#ccc solid 1px;">
               <div class="sidePanelTitle" style="margin-bottom:15px;">
                 <span style="color:#990000;">NEWSFACTOR NETWORK</span> SITES
               </div>
               <div>

                <div class="stdLinks" style="padding-left:20px;font-size:13pt;color:#444;">Enterprise I.T. Sites:</div>
                  <ul>
                   <li class="stdLinks"> <a href="http://www.newsfactor.com/">NewsFactor Technology News</a> 
                   <li class="stdLinks"> <a href="http://www.enterprise-security-today.com/">Enterprise Security Today</a> 
                   <li class="stdLinks"> <a href="http://www.crm-daily.com/">CRM Daily</a>
                 </ul>
                <div class="stdLinks" style="padding-left:20px;font-size:13pt;color:#444;" style="padding-top:20px;">Business & Innovation Sites:</div>
                 <ul>
                  <li class="stdLinks"> <a href="http://www.sci-tech-today.com/">Sci-Tech Today</a> 
                  <li class="stdLinks"> <a href="http://business.newsfactor.com/">NewsFactor Business Report</a>
                 </ul>
               </div>
             </td>

             <td width="33%" valign="top">
               <div class="sidePanelTitle">
                 <span style="color:#990000;">NEWSFACTOR</span> SERVICES
               </div>
                <div>
                 <ul>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/share/nfn_doc.php?d=3RFS">About NewsFactor Network</a> 
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/share/nfn_doc.php?d=68YFSA72"><b>How To Advertise</b></a>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/members.xhtml">Free Newsletters</a>
                     <div style="padding:15px;"></div>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/share/contact.xhtml">How To Contact Us</a> 
                     <div style="padding:15px;"></div>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/access/pr/">Services for PR Pros</a>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/access/pr/">SEO Services</a>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/access/pr/">Sponsored Content Services</a>
                     <div style="padding:15px;"></div>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/share/nfn_doc.php?d=7SW98RTG">Article Reprints</a> 
                     <li class="stdLinks"> <a href="http://www.toptechwire.com/">Top Tech Wire</a>
                     <div style="padding:15px;"></div>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/share/nfn_doc.php?d=GR45OU5">Privacy Policy</a>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/share/nfn_doc.php?d=GR45OU5">Terms of Service</a>
                 </ul
                </div>
             </td>

           </tr>
          </table>
    </div>  
   <div style="background:#919191;">
    <div class="tinyText14" style="width:980px;padding:5px;text-align:right;">
&#169; Copyright 2016 NewsFactor Network. All rights reserved. Member of <a href='http://www.accuserveadsystem.com'>Accuserve Ad Network</a>.
    </div>
   </div></center></div>
<script type="text/javascript">
/* <![CDATA[ */
var google_conversion_id = 957885861;
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]> */
</script>
<script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
</script>
<noscript>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/957885861/?value=0&amp;guid=ON&amp;script=0"/>
</div>
</noscript>

     </body>
    </html>


