  <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
  <html lang="en" prefix="og: http://ogp.me/ns#">
  <head>
  <title>How a Tiny Cybersecurity Firm Stopped a Global Ransomware Attack | Enterprise Security Today</title>
  <meta property="og:title" content="How a Tiny Cybersecurity Firm Stopped a Global Ransomware Attack | Enterprise Security Today" />
  <meta property="og:type" content="website" />
  <meta property="og:url" content="http://www.enterprise-security-today.com/story.xhtml?story_id=012000EWL9C0" />
  <meta property="og:image" content="http://www.enterprise-security-today.com/images/super/larger-16-CYBERSECURITY-alert-hack-detected1.jpg" />
  <meta property="og:image:type" content="image/jpg">
  <meta property="og:image:width" content="593">
  <meta property="og:image:height" content="290">
  <meta property="og:description" content="The mid-May WannaCry episode thrust a small Los Angeles cybersecurity company onto a world stage. At the same time, it has opened a new era of broad-scale ransomware attacks." />
  <meta prefix="fb: http://ogp.me/ns/fb#" property="fb:app_id" content="104421319604025">
  <!-- twitter meta -->
  <meta name="twitter:card" content="summary_large_image">
  <meta name="twitter:site" content="@newsfactor">
  <meta name="twitter:title" content="How a Tiny Cybersecurity Firm Stopped a Global Ransomware Attack | Enterprise Security Today">
  <meta name="twitter:description" content="The mid-May WannaCry episode thrust a small Los Angeles cybersecurity company onto a world stage. At the same time, it has opened a new era of broad-scale ransomware attacks.">
  <meta name="twitter:image:src" content="http://www.enterprise-security-today.com/images/super/larger-16-CYBERSECURITY-alert-hack-detected1.jpg">
  <!-- / twitter meta -->
  <meta name="medium" content="news" />
  <meta name="title" content="How a Tiny Cybersecurity Firm Stopped a Global Ransomware Attack | Enterprise Security Today - Network Security News" />
  <meta http-equiv="Content-Type" content="text/html;charset=UTF-8" />
  <meta name="headline" content="How a Tiny Cybersecurity Firm Stopped a Global Ransomware Attack | Enterprise Security Today - Network Security News" />
  <meta name="created" content="2017-06-30 09:01:17" />
  <meta name="DC.date.issued" content="2017-06-30"> 
  <meta name="keywords" content="Cybercrime,Cybersecurity,Ransomware,Russia,Hacker,Wannacry,NSA,Malware" />
  <meta name="description" content="The mid-May WannaCry episode thrust a small Los Angeles cybersecurity company onto a world stage. At the same time, it has opened a new era of broad-scale ransomware attacks." />
  <meta name="syndication-source" content="http://www.enterprise-security-today.com/story.xhtml?story_id=012000EWL9C0" />
  <META name="ROBOTS" content="NOARCHIVE" />
  <META name="Expires" content="0" />
  <META Http-Equiv="Expires" Content="0" />
  <META Http-Equiv="Cache-Control" Content="no-cache" />
  <META Http-Equiv="Pragma" Content="no-cache" />
  <link rel="alternate" type="application/rss+xml" title="Enterprise Security Today RSS Feed" href="/share/rss_feed.php" />
  <link rel="SHORTCUT ICON" HREF="http://newsfactor.com/favicon.ico" />
  <link rel="canonical" href="http://www.enterprise-security-today.com/story.xhtml?story_id=012000EWL9C0" />
  <link rel="stylesheet" href="//code.jquery.com/ui/1.11.1/themes/smoothness/jquery-ui.css">
  <link rel="stylesheet" href="/share/nfn-style-2012.css" type="text/css" />
  <link href='http://fonts.googleapis.com/css?family=Oxygen' rel='stylesheet' type='text/css'>
  <link href="http://fonts.googleapis.com/css?family=Bree+Serif" rel="stylesheet" type="text/css">
  <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>
  <script src="http://code.jquery.com/ui/1.11.1/jquery-ui.js"></script>
  <! -- script src="/share/nfn_extra_script1_14.js"--><!-- /script-->
  <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  
    ga('create', 'UA-2948378-1', 'auto');
    ga('send', 'pageview');
  
  </script>
  <script>(function() {
    var _fbq = window._fbq || (window._fbq = []);
    if (!_fbq.loaded) {
      var fbds = document.createElement('script');
      fbds.async = true;
      fbds.src = '//connect.facebook.net/en_US/fbds.js';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(fbds, s);
      _fbq.loaded = true;
    }
    _fbq.push(['addPixelId', '1469526266648474']);
  })();
  window._fbq = window._fbq || [];
  window._fbq.push(['track', 'PixelInitialized', {}]);
  </script>
  <noscript><img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=1469526266648474&amp;ev=NoScript" /></noscript>

      <script>
        $(document).ready(function(){
            // Next Article
           var nextArticleURL = "/share/nfn_ajaxFunctions14.php?do=5RT82WD&params=" + $("#activateNextArticle").attr("name");
           $("#nextArticleCanvass").load (nextArticleURL);

            // Tooltips
            $(function() {
              $(document).tooltip();
            });

            // Toggles the top site menu
            $( "#siteMenuActivate" ).add( "#closeMenuCanvass" ).click(function() {
              $( "#siteMenuCanvass" ).slideToggle( "slow" );
              $( "#siteMenuCanvass" ).css('position', 'fixed');
            });

            $( "#superGraphicTeaserActivate" ).click(function() {
              $( "#superGraphicTeaser" ).slideToggle( "slow" );
              $('#superGraphicTeaserRiserContainer').slideToggle( "slow" ); 
            });

            $('#superGraphicTeaserRiserActivate').mouseenter(function() {
              $( "#superGraphicTeaser" ).slideToggle( "slow" );
              $('#superGraphicTeaserRiserContainer').slideToggle( "slow" );
            });

            // Closes the welcome ad
            $( "#rollupbutton" ).click(function() {
              $( "#expandable_welcome_ad" ).slideToggle( "slow" );
            });

            // Closes the breaking news announcement box
            $( "#announcement_cls" ).click(function() {
              $( "#annoucement_canvass" ).toggle( "fade" );
              $.cookie("spc_annc", 1);
            });

            $(window).scroll(function(){
               // Causes the fixed top row shadow to appear 
               if ($(this).scrollTop() > 5) {
                  $('#shadow4fixedDiv').fadeIn("slow");
               } else {
                   $('#shadow4fixedDiv').hide();
                 }
            });

        });
      </script>

      <script src="http://www.enterprise-security-today.com/share/showads.js"></script>
  </head>
  <body>

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=104421319604025&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<script>
   $(document).ready(function(){
      //ab_detection
      function showAbNotice() {
       $('#screen_cover').toggle();
       $('#ab_notice').toggle('slow');   
      } 
      if( window.canRunAds === undefined ){
       // adblocker detected, show fallbac
       showAbNotice();
      }
      $( "#ab_notice_closer" ).click(function() {
        $( "#ab_notice" ).toggle( "fade" );
        $( "#screen_cover" ).toggle( "fade" );
      });
   });
    </script>

   <center>
<div id="screen_cover" class="entire_screen_cover">
</div>
  <div id="ab_notice" class="ab_notice_canvass">
   <div class="inner_ab_notice">
    <div class="top_and_bottom_borders">
    <div style="font-size:18pt;">
      Dear Visitor,
    </div>
  <p>
  Our system has found that you are using an ad-blocking browser add-on.
  <p>
  We just wanted to let you know that our site content is, of course,
  available to you absolutely free of charge.
  <p>
  Our ads are the only way we have to be able to bring you the latest
  high-quality content, which is written by professional journalists,
  with the help of editors, graphic designers, and our site production
  and I.T. staff, as well as many other talented people who work around the clock
  for this site.
  <p>
  So, we ask you to add this site to your Ad Blocker’s "white list" or
  to simply disable your Ad Blocker while visiting this site.
  <p>
  <div style="padding-top:10px;">
   <span id="ab_notice_closer" class="bigBtn14" style="display:inline-block;">
    Continue on this site freely
   </span>
     </div>
    </div>
   </div>
  </div>
<div class="spacerRow"></div>

        <div class="fixedHeader"> 
         <div style="background:#222;">
          <table width="980" cellpadding="0" cellspacing="0" border="0">
           <tr>
            <td style="background:#990000;width:250px;">&nbsp;</td>
            <td style="padding-left:10px;padding-right:10px;">
              <span class="smallWhiteLinks14" id="homeLinkActivate"><a title="Home" href="http://www.enterprise-security-today.com"><img src="http://www.enterprise-security-today.com/share/images/site/icon-home14.png" width="14" height="14" border="0" style="padding-right:5px;">HOME</a></span> &nbsp; &nbsp; 
              <span class="smallWhiteLinks14" id="siteMenuActivate"><a title="Site Menu" href="#"><img src="http://www.enterprise-security-today.com/share/images/site/icon-menu14.png" width="14" height="14" border="0" style="padding-right:5px;">MENU</a></span> &nbsp; &nbsp;
            </td>
            <td align="right">
              <span class="smallWhiteLinks14"><a title="Search This Site" data-transition="slidedown" href="http://www.enterprise-security-today.com/search.xhtml"><img src="http://www.enterprise-security-today.com/share/images/site/icon-search14.png" width="14" height="14" border="0" style="padding-right:5px;">SEARCH</a></span> &nbsp; &nbsp;
              <span class="smallWhiteLinks14"><a title="Stay Up To Date With A Free Newsletter" href="http://www.newsfactor.com/members.xhtml"><img src="http://www.enterprise-security-today.com/share/images/site/icon-newsletter14.png" width="14" height="14" border="0" style="padding-right:5px;">NEWSLETTER</a></span> &nbsp; &nbsp;
            </td>
            <td style="background:#fff;width:108px;padding-top:5px;" align="center">
             <a title="Follow us on Facebook" href="https://www.facebook.com/Newsfactornetwork"><img id="moreTransparency1" src="http://www.enterprise-security-today.com/share/images/site/icon-facebook-grey2.png" width="23" height="24" border="0"></a>
             <a title="Follow our Twitter feed" href="https://twitter.com/newsfactor"><img id="moreTransparency1" style="padding-left:15px;" src="http://www.enterprise-security-today.com/share/images/site/icon-twitter-grey2.png" width="28" height="24" border="0"></a> 
            </td>
           </tr>
          </table>
         </div>
         <div style="background:#fff;display:block;padding-bottom:20px;padding-top:0px;">
          <table width="980" cellpadding="0" cellspacing="0" border="0">
           <tr>
            <td align="center" style="background:#990000;width:250px;border-top:#990000 solid 1px;border-radius:0px 0px 5px 5px;"><a title="Home" href="http://www.enterprise-security-today.com" target="_top"><img id="notransparency" src="http://images.newsfactor.com/share/images/site/est-logo.gif" width="387" height="26" border="0"></a></td>
            <td class="tinyText14" style="background:#fff;padding-left:10px;">
             THE ENTERPRISE SECURITY SUPERSITE. UPDATED ABOUT A MINUTE AGO.
            </td>
          </table>
         </div>

  <!-- Site Menu -->
  <div id="siteMenuCanvass" class="siteMenuCanvass">
          <div class="stdLinks" style="text-align:left;padding:10px;">
            <div style="position:absolute;top:1px;right:-4px;"><a href="#"><img id="closeMenuCanvass" src="http://www.enterprise-security-today.com/share/images/site/close-round1.png" width="42" height="42" border=""></a></div>
            <div class="siteMenuItem"><a href="http://www.enterprise-security-today.com">Home</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=75">Network Security</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=5">Viruses & Malware</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=244">Cybercrime</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=160">Security Solutions</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=207">Mobile Security</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=262">Disaster Recovery</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=159">Windows Security</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=212">Data Security</a></div><div class="siteMenuItem"><a href="http://www.enterprise-security-today.com/section.xhtml?category=155">EST Contributed Content</a></div>  </div>
         </div>
<!-- // Site Menu -->
         <div class="shadowRow1" id="shadow4fixedDiv"></div>
        </div><table cellpadding="0" cellspacing="0" border="0" width="980">
             <tr>
              <td> <div class="nfnNavCrumbs14" style="border-top:#ccc8c8 solid 1px;border-bottom:#ccc8c8 solid 1px;margin-top:10px;margin-bottom:10px;"><img src="http://images.newsfactor.com/share/images/site/spacer.gif" width="5" height="38" border="0" align="absmiddle">
              You are here: 
              <a href="http://www.enterprise-security-today.com">Home</a> / <a href='http://www.enterprise-security-today.com/section.xhtml?category=075'>Network Security</a> / How Kryptos Stopped WannaCry</div></td>
              <td align="right"> <div class="nfnNavCrumbs14" style="height:24px;padding:7px;border-top:#ccc8c8 solid 1px;border-bottom:#ccc8c8 solid 1px;margin-top:10px;margin-bottom:10px;">
</div></td>
           </tr>
           <tr>
            <td colspan="2">
              <table cellpadding="0" cellspacing="0" border="0" width="100%">
                <tr> <td style="padding-top:3px; padding-bottom:3px;"></td> <td style="padding-top:3px; padding-bottom:3px;" align="center" width='240'>    </td>
                    </tr>
                 </table>
                </td>
           </tr>
  
  </table>
  <!-- / Fade -->  
  
<table cellpadding="0" cellspacing="0" width="980" border="0">
           <tr>
            <td valign="top" bgcolor="#FFFFFF"><!--body-->
         <div class='regtext'>
 <div style="border-top:#555 solid 3px;margin-top:10px;margin-bottom:10px;"></div>
         <table cellpadding="0" cellspacing="0" border="0">
         <tr>
          <td colspan="2" style="border-right:#ddd solid 1px;" valign="top">
           <div style="padding:5px;">
            <img id="notransparency" src="http://www.sci-tech-today.com/images/super/larger-16-CYBERSECURITY-alert-hack-detected1.jpg" width="100%" border="0" alt="How a Tiny Cybersecurity Firm Stopped a Global Ransomware Attack">
           </div>
           <div class="articleHeadline14">
            How a Tiny Cybersecurity Firm Stopped a Global Ransomware Attack
           </div>
           <div style="padding:10px;border-top:#999 solid 1px;border-bottom:#999 solid 1px;">
            <table cellpadding="0" cellspacing="0" width="100%">
             <tr> <!--byline-->
            <td class='articleByline14'>By Jill Leovy </td>
           <!--/byline-->
         <td align="right">
                <a title="Share this on Facebook" href="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.enterprise-security-today.com/story.xhtml?story_id=012000EWL9C0&t=How+a+Tiny+Cybersecurity+Firm+Stopped+a+Global+Ransomware+Attack"><img id="moreTransparency1" src="http://images.newsfactor.com/share/images/site/icon-facebook-round.png" width="25" height="27" border="0" alt="Like this on Facebook"></a>
                <a title="Share this on Twitter" href="http://twitter.com/intent/tweet?text=How+a+Tiny+Cybersecurity+Firm+Stopped+a+Global+Ransomware+Attack&url=http%3A%2F%2Fwww.enterprise-security-today.com/story.xhtml?story_id=012000EWL9C0"><img id="moreTransparency1" src="http://images.newsfactor.com/share/images/site/icon-twitter-round.png" width="25" height="27" border="0" alt="Tweet this"></a>
                <a title="Share this on LinkedIn" href="http://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fwww.enterprise-security-today.com/story.xhtml?story_id=012000EWL9C0&title=How+a+Tiny+Cybersecurity+Firm+Stopped+a+Global+Ransomware+Attack&summary=The+mid-May+WannaCry+episode+thrust+a+small+Los+Angeles+cybersecurity+company+onto+a+world+stage.+At+the+same+time%2C+it+has+opened+a+new+era+of+broad-scale+ransomware+attacks.&source=Enterprise Security Today"><img id="moreTransparency1" src="http://images.newsfactor.com/share/images/site/icon-linkedin-round.png" width="25" height="27" border="0" alt="Link thison Linkedin"></a>
                <a title="Share this on Google+" href="https://plus.google.com/share?url=http%3A%2F%2Fwww.enterprise-security-today.com/story.xhtml?story_id=012000EWL9C0"><img id="moreTransparency1" src="http://images.newsfactor.com/share/images/site/icon-googleplus-round.png" width="25" height="27" border="0" alt="Link this on Google Plus"></a>
               </td>
              </tr>
             </table>
           </div>

          <div style="float:left; padding:5px 10px 15px; 15px; width:160px; height:100%;"><div class="fancyDateContainer">
                   <div class="fancydatePublished">PUBLISHED:</div>
                   <div class="fancydateMonth">JUNE</div>
                   <div class="fancyDateDay">30</div>
                   <div class="fancydateYear">2017</div>
                  </div>
                  </div><div style="padding:0px;float:right;"><iframe id='editcheck' name='editcheck' src='http://www.newsfactor.com/share/new_editcheck.xhtml?story_id=105504' width='100' height='5' frameborder='0' scrolling='no' MARGINWIDTH='0' MARGINHEIGHT='0' HSPACE='0' VSPACE='0' FRAMEBORDER='0' SCROLLING='no' BORDERCOLOR='#000000'>
          </iframe>
</div>
               <div id="Main_body" class="articleBodyText14" style="padding:10px;">
             Salim Neino had been waiting for something like WannaCry. Fast, indiscriminate and disruptive, the computer infection locked up computers in British hospitals and was spreading across the world when Neino's company Kryptos Logic stepped into the ring.
<p>
One of his researchers found a so-called kill switch in the WannaCry code and pounced. "We put it in a triangle choke!" joked Neino, a mixed-martial-arts fan.
<p>
Not bad for a 33-year-old Lawndale native and Cal State Long Beach grad, who co-founded Kryptos eight years ago with $120,000.
<p>
The mid-May episode thrust the small Los Angeles cybersecurity company onto a world stage. At the same time, it has opened a new era of broad-scale ransomware attacks -- a fact driven home this week when a second worm, exploiting the same methods as WannaCry, briefly seized computers worldwide again, this time hitting oil, electric and shipping operations.
<p>
Neino has been quick to capitalize on the business opportunities from his new prominence. But he has also tried to use this status as ransomware wrangler to push for policy changes -- measures he says are needed to cope with this new landscape of cyber-mayhem.
<p>
Testifying before Congress between attacks, Neino spelled out his proposal for a cybersecurity "Richter scale" -- a triage system to help the public prioritize threats -- and warned lawmakers against underrating the peril.
<p>
With WannaCry, and Tuesday's reprise of it, the world got off easy, he insisted: "They had the bomb, they didn't have the GPS."
<p>
Up until last month, Kryptos was just another little-known boutique cybersecurity company operating, as much as possible, "in stealth mode," Neino said. It does no marketing, employs no sales force and its workers guard their anonymity. The reason is that revenge hackers commonly target cybersecurity companies.
<p>
Genial, earnest and still fit from his wrestling days, Neino is the son of a Jordanian immigrant father and a Mexican American mother from Montebello. His father came to L.A. as a young man with no English but talent enough to rise in the region's aerospace industry.
<p>
Neino was raised speaking Arabic and Spanish, but he can't remember either language now. Maybe code took over that brain space, he said. He got his start as a self-taught teenage programmer, landed his first computer job at age 15, and became -- after a sister -- the second person in his family to go to college.
<p>
The background, he said, is typical of Angelenos his age raised by aerospace workers to whom cyber-tinkering came naturally.
<p>
After a few years as an independent cybersecurity specialist, Neino co-founded Kryptos while still in his twenties with friends-and-family seed money, and has used its revenue to expand ever since.
<p>
At first, Kryptos struggled. Neino could show potential clients that they had been hacked, but he couldn't convince them to care.
<p>
The problem is rife in cybersecurity, a vast but fuzzily defined industry sector worth perhaps hundreds of billions of dollars in the near future -- if only its purveyors could explain what it's for.
<p>
People who are good at cybersecurity tend to speak in jargon; people who aren't good at cybersecurity can't understand them. Meanwhile, the fire hose of botnets and malware gushing through the Internet these days leaves victims feeling helpless. Throngs of companies peddle a mishmash of remedies -- gadgets, software and services, in various combinations.
<p>
Then, on a lark, Neino joined a team that competed at the 2011 Defcon 19 hacking contest in Las Vegas and won a coveted Black Badge, a tchotchke shaped like a skull, almost actual size, designed to hang around the neck. The boost to Kryptos' reputation brought new clients and lucrative contracts.
<p>
Today, privately held Kryptos has about 25 employees -- nearly all engineers spread out across the U.S. and Europe, nearly all male, many with self-taught hacking skills -- and annual revenue in the tens of millions. Its young CEO has traded blue-collar Lawndale for an ocean-view home. The Black Badge is on display in his office.
<p>
The company gathers information about who is trying to hack its clients and why. Then it helps them decide how to fight back.
<p>
Day to day, its researchers spend their time reporting on malware to subscribers, and tracking the tens of thousands of new malware codes that surface daily on the Web.
<p>
In essence, they operate like zoologists in the field: They detect malicious sequences by the signals they emit, catalog them and try to lure them into simulated targets so they can be dissected.
<p>
This is what Marcus Hutchins, a Kryptos researcher based in the town of Ilfracombe on the Bristol Channel in Southwest England, would have been doing on the morning of May 12 if he hadn't been on vacation. Neino was too -- on his way to Italy for a long-planned vacation with his wife.
<p>
Neino had hired Hutchins last year after coming across his blog. An unemployed computer hobbyist and surfer, Hutchins impressed Neino with his skill and ethics. Despite his youth -- Hutchins is 22 -- Neino hired him to run one of his divisions.
<p>
Fortunately for Kryptos -- and for unpatched Windows systems everywhere -- Hutchins hadn't gone far from home.
<p>
As computers in Britain hospitals locked up and companies in Europe started to report problems, Hutchins conferred with Neino, who was in a hotel in Munich, Germany, on his way to catch his plane to Venice, Italy. Hutchins began analyzing samples of the malware code, sharing information via Twitter with other cyber researchers.
<p>
WannaCry is a self-replicating worm that attacks a basic file-sharing protocol on older Windows operating systems. If successfully loaded, the ransomware spreads to any connected vulnerable terminal, locking files and demanding, in slightly broken English, $300 to $600 ransom to release them.
<p>
The worm exploits a vulnerability embedded in the very bones of the world's most popular operating system. The code used in WannaCry, which can crack Windows systems, was stolen from the U.S. National Security Agency and shared on the Internet.
<p>
Like many in his industry, Neino knew that it was only a matter of time before ordinary bandits or terrorists put these military-grade spy tools to work. WannaCry, he realized, signaled that the moment had arrived.
<p>
From now on, he thought, vast sophisticated hacks, once limited to nation states, would be in reach of just about anyone.
<p>
Neino learned that Hutchins had found an unregistered domain to which WannaCry sent a signal prior to loading. Neither of them knew what it was for. But it was up for grabs.
<p>
Neino told Hutchins to "use best judgment" and headed to the airport.
<p>
By the time Neino got there, Hutchins had registered the domain, effectively throwing Kryptos' servers into the path of the oncoming attack. To both men's surprise, the domain functioned as a kill switch and stopped WannaCry from loading the ransom note in all subsequent infections.
<p>
With Kyptos controlling the domain, each new WannaCry infection produced a ping on its servers. So a stream of data was pouring in as the attack -- now toothless -- spread across the globe.
<p>
Neino couldn't log into Kryptos to see for himself because he had no secure connection and his plane was leaving. He flew over the Alps, two worries gnawing at him.
<p>
One was for Hutchins' safety. Because of blanket media coverage, Neino feared that Hutchins would be exposed and hackers would retaliate against him.
<p>
The other was for Kryptos' servers. Because the company had essentially inserted itself into WannaCry's protocol, Neino knew that law enforcement agencies might mistake the company for a source of the attack and seek to shut down its servers. That could inadvertently unleash the malware again.
<p>
Online again at last in his Venice hotel, he checked the dashboard, where tens of thousands of WannaCry's pings were piling up.
<p>
He didn't have time to marvel. Kryptos was under siege. Hutchins was being hounded. The story of the youthful hero who saved humanity from the world's biggest ransomware attack proved irresistible to aggressive British tabloids.
<p>
At the same time, hackers were attacking Kryptos. As soon as word of the kill switch got out, a barrage of denial-of-service attacks were directed at the company's servers worldwide.
<p>
This "devilish flood" of malicious botnets and copycat hacks was the company's reward for stopping the worm, Neino said. He called some of the attackers "bandwagon jumpers" and said they probably just wanted to be pesky. But others were clearly trying to "take down the switch," he said -- a serious threat.
<p>
Already, just as Neino had feared, two of Kryptos' servers had been mistakenly shut down by authorities in France, a common cyber friendly-fire mishap.
<p>
His engineers pulled all-nighters. Neino spent his 10-day vacation hunched over his laptop in the hotel room, talking to security agencies, assuaging the media, managing his researchers and maintaining the kill switch. His wife made sure that he didn't forget to eat.
<p>
Attacks on Kryptos have continued for weeks. One recent botnet aimed at the company appeared to be coming from thousands of Russian routers, Neino said.
<p>
To the outside world, WannaCry quickly seemed overblown. One British publication suggested that it be renamed "What-a-wimp."
<p>
It's design was shoddy. Neino readily admits that Hutchins' got lucky with the kill switch -- ransomware usually doesn't have such a feature and it's not clear why this one did. Microsoft had patched a key vulnerability before the attack and subsequently released further patches, and Neino said the worm failed to load on most of the old Windows XP systems considered most vulnerable anyway.
<p>
Moreover, very few people paid the bitcoin ransom, which has yet to be collected.
<p>
But at Kryptos, where the kill switch remains permanently under guard -- "we own this baby now," Neino said -- the picture is different. Neino said he has counted new WannaCry infections in the tens of millions -- infections that Hutchins' quick action had rendered harmless.
<p>
Kryptos has a list of "every single person affected by WannaCry," he said. Among the would-be victims were major U.S. hospitals whose leaders may still have no idea, he told Congress.
<p>
"The brakes were fully on. This was residual smoke from the tires," Neino said.
<p>
Like WannaCry, Tuesday's ransomware attack centered in Ukraine also seemed to quickly fizzle. It used the same stolen NSA forced-entry tool, locked computers and demanded bitcoin ransom, with similarly poor results.
<p>
But Neino said it spread even more quickly, infecting 2 million computers in the first hour. It also had the ability to steal credentials and gain access to even more machines.
<p>
Most different of all, it had no kill switch. Instead, the attack seemed to shut down by itself, Neino said, with domains that hosted its payload quickly going dark.
<p>
Using his data from WannaCry, Neino published a report late Tuesday arguing that this new worm had even greater destructive potential.
<p>
By his own "Richter scale" measure, WannaCry might have rated a 7 and the new attack 7.2, said Neino, speaking as one raised in an earthquake zone. The pattern, suggests "saber rattling, perhaps for a bigger event to come," he said.
<p>
The day after the most recent attack, with theories swirling as to its purpose, Neino stressed a message that he'd given Congress after WannaCry:
<p>
Worry less about who did it, and more about the problems such attacks expose, he said.
<p>
"If you leave the door open ... would it really matter ... who has done it?" he asked. "They do it because they can."
<!--copyright-->
           <div class="smalltext" style="padding:15px 0px 10px 0px;">&copy; 2017 Los Angeles Times under contract with NewsEdge/Acquire Media. All rights reserved.</div>
          <!--/copyright-->
<div style="padding-top:10px;">
               <!--Image Credit-->
               <span class=smalltext14><p><i>Image credit: iStock.</i></span>
              </div>
             <!--/Image credit--><div style="clear:both;padding:15px 15px 25px 0px;">
          <b>Read more on:</b> <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Cybercrime%22&sort=time">Cybercrime</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Cybersecurity%22&sort=time">Cybersecurity</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Ransomware%22&sort=time">Ransomware</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Russia%22&sort=time">Russia</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Hacker%22&sort=time">Hacker</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Wannacry%22&sort=time">Wannacry</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22NSA%22&sort=time">NSA</a>, <a href="http://www.enterprise-security-today.com/search.xhtml?cat_description=search&query=%22Malware%22&sort=time">Malware</a></div><div style="clear:both;"><div style='background:#DCE2ED;padding:7px;border:#ACB1BA solid 1px;'>
                    <table cellpadding='3' cellspacing='0'>
                     <form action='' method='post'>
                     <tr>
                      <td colspan='2'>
                       <div class='bigDate'>Tell Us What You Think</div>
                      </td>
                     </tr>
                     <tr>
                     <td valign='top' class='smallText14' colspan='2'>
                      <b>Comment:</b>
                      <br>
                      <textarea style='font-size:12pt;' cols='55' rows='5' name='comment_body'></textarea>
        <p>
      <b>Name:</b><br><input type='text' size='30' name='comment_username' style='font-size:12pt;'>
                      </td>
                     </tr>
                     <tr>
                     <td>
                      <input type='hidden' name='comment_aid' value='105504'>
                      <input type='hidden' name='do' value='PREVIEW YOUR COMMENT'>
                      <input type='hidden' name='article_title' value='How a Tiny Cybersecurity Firm Stopped a Global Ransomware Attack'>
                      <input type='submit' value='Send' class='regBtn14'>
                     </td>
                     </tr>
                     </form>
                    </table>
                    </div><p></div>  </div>
          </td>
          <td width="320" valign="top" align="center">
           <div style="padding:5px;border-bottom:#ccc solid 1px;">
            <a title="Like / Follow us on Facebook" href="https://www.facebook.com/Newsfactornetwork"><img src="http://images.newsfactor.com/share/images/site/like-us.png" width="150" height="34" border="0" alt="Like Us on Facebook"></a><a title="Follow our Twitter Feed" href="https://twitter.com/newsfactor"><img src="http://images.newsfactor.com/share/images/site/follow-us.png" width="150" height="34" border="0" alt="Follow Us on Twitter"></a>
           </div>
           <div style="padding-top:10px;padding-bottom:20px;">   </div> <div style="padding-top:0px;padding-bottom:20px;"> <div class="sidePanelTitle"">
            <span style="color:#990000;">TOP STORIES</span> NOW
           </div>
           <img src="http://www.newsfactor.com/images/2012/imu_shadow.gif">
          <div style="text-align:left;padding-top:0px;padding-bottom:25px;">
           <div class="sidepanelitem"><span class="greyText1">1.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=01200010H5CO">Facebook, Google Helped Ukrainians</a><p><span class="greyText1">2.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=01200010H5AO">Malware Patient Zero Facing Charges</a><p><span class="greyText1">3.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=01200010H58C">Cloud-First Focus Prompts MS Reorg</a><p><span class="greyText1">4.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=01200010H57C">Qualcomm Intros Fingerprint Sensors</a><p><span class="greyText1">5.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=01200010H59O">Companies Recovering from Attack</a><p> </div>
         </div><div class="sidePanelTitle">
          <span style="color:#990000;">MAY INTEREST</span> YOU 
         </div>
        <img src="http://www.newsfactor.com/images/2012/imu_shadow.gif">
        <div style="padding:10px;padding-top:0px;padding-bottom:20px;">
          <div class="cipText14" style="padding:10px;padding-top:0px;text-align:left;"> </div>
         </div> <div style="padding-top:10px;padding-bottom:20px;"> </div>
         </div>
           <div class="sidePanelTitle"><span style="color:#990000;">MORE IN</span> NETWORK SECURITY
           </div>
           <img src="http://www.newsfactor.com/images/2012/imu_shadow.gif">
<div class="sidePanelItem" style="padding-bottom:15px;"><span class="greyText1">1.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=012000EWL9F0">Companies Recovering from Attack</a></div><div class="sidePanelItem" style="padding-bottom:15px;"><span class="greyText1">2.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=012000EWL9CC">Surprising Details about Petya Attack</a></div><div class="sidePanelItem" style="padding-bottom:15px;"><span class="greyText1">3.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=012000EWL9C0">How Kryptos Stopped WannaCry</a></div><div class="sidePanelItem" style="padding-bottom:15px;"><span class="greyText1">4.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=012000EWL9AC">How AI Is Taking on Ransomware</a></div><div class="sidePanelItem" style="padding-bottom:15px;"><span class="greyText1">5.</span> <a href="http://www.enterprise-security-today.com/story.xhtml?story_id=012000EWL990">Cisco Live's Big News & Revelations</a></div><div style="padding-top:20px;padding-bottom:20px;"></div>
           </td>
          </tr> </table> 
            </div>
            </div>
                </td>
               </tr>
              </table>

<!-- Navigation -->
          <div style="background:#eee; border-top:#c0c0c0 solid 5px;margin-top:20px;padding-top:20px;">
           <table cellpadding="5" cellspacing="0" width="980" border="0">
           <tr>
             <td width="33%" valign="top" style="border-right:#ccc solid 1px;">
               <div class="sidePanelTitle">
               ENTERPRISE SECURITY TODAY
               </div>
               <div>
                <ul><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=75'>Network Security</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=5'>Viruses & Malware</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=244'>Cybercrime</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=160'>Security Solutions</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=207'>Mobile Security</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=262'>Disaster Recovery</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=159'>Windows Security</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=212'>Data Security</a><li class="stdLinks"> <a href='http://www.enterprise-security-today.com/section.xhtml?category=155'>EST Contributed Content</a>
                </ul>
               </div>
             </td>

             <td width="33%" valign="top"  style="border-right:#ccc solid 1px;">
               <div class="sidePanelTitle" style="margin-bottom:15px;">
                 <span style="color:#990000;">NEWSFACTOR NETWORK</span> SITES
               </div>
               <div>

                <div class="stdLinks" style="padding-left:20px;font-size:13pt;color:#444;">Enterprise I.T. Sites:</div>
                  <ul>
                   <li class="stdLinks"> <a href="http://www.newsfactor.com/">NewsFactor Technology News</a> 
                   <li class="stdLinks"> <a href="http://www.enterprise-security-today.com/">Enterprise Security Today</a> 
                   <li class="stdLinks"> <a href="http://www.crm-daily.com/">CRM Daily</a>
                 </ul>
                <div class="stdLinks" style="padding-left:20px;font-size:13pt;color:#444;" style="padding-top:20px;">Business & Innovation Sites:</div>
                 <ul>
                  <li class="stdLinks"> <a href="http://www.sci-tech-today.com/">Sci-Tech Today</a> 
                  <li class="stdLinks"> <a href="http://business.newsfactor.com/">NewsFactor Business Report</a>
                 </ul>
               </div>
             </td>

             <td width="33%" valign="top">
               <div class="sidePanelTitle">
                 <span style="color:#990000;">NEWSFACTOR</span> SERVICES
               </div>
                <div>
                 <ul>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/share/nfn_doc.php?d=3RFS">About NewsFactor Network</a> 
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/share/nfn_doc.php?d=68YFSA72"><b>How To Advertise</b></a>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/members.xhtml">Free Newsletters</a>
                     <div style="padding:15px;"></div>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/share/contact.xhtml">How To Contact Us</a> 
                     <div style="padding:15px;"></div>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/access/pr/">Services for PR Pros</a>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/access/pr/">SEO Services</a>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/access/pr/">Sponsored Content Services</a>
                     <div style="padding:15px;"></div>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/share/nfn_doc.php?d=7SW98RTG">Article Reprints</a> 
                     <li class="stdLinks"> <a href="http://www.toptechwire.com/">Top Tech Wire</a>
                     <div style="padding:15px;"></div>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/share/nfn_doc.php?d=GR45OU5">Privacy Policy</a>
                     <li class="stdLinks"> <a href="http://www.newsfactor.com/share/nfn_doc.php?d=GR45OU5">Terms of Service</a>
                 </ul
                </div>
             </td>

           </tr>
          </table>
    </div>  
   <div style="background:#919191;">
    <div class="tinyText14" style="width:980px;padding:5px;text-align:right;">
&#169; Copyright 2017 NewsFactor Network. All rights reserved. Member of <a href='http://www.accuserveadsystem.com'>Accuserve Ad Network</a>.
    </div>
   </div></center></div>
<script type="text/javascript">
/* <![CDATA[ */
var google_conversion_id = 957885861;
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]> */
</script>
<script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
</script>
<noscript>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/957885861/?value=0&amp;guid=ON&amp;script=0"/>
</div>
</noscript>

     </body>
    </html>


